Commit 9569dc90 authored by Matthias Möller's avatar Matthias Möller
Browse files

using acg version check instead of qt

git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@17165 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 6f223c94
......@@ -50,9 +50,6 @@
#include <QFileInfo>
#include <QDir>
#include <QTextStream>
#undef QT_NO_OPENGL
#include <QGLFormat>
#define QT_NO_OPENGL
namespace ACG
{
......@@ -429,9 +426,8 @@ ShaderProgGenerator::ShaderProgGenerator(const ShaderGenDesc* _desc,
{
desc_ = *_desc;
// We need at least version 2.0 or higher to support geometry shaders
QGLFormat::OpenGLVersionFlags flags = QGLFormat::openGLVersionFlags();
desc_.geometryShader &= flags.testFlag(QGLFormat::OpenGL_Version_3_2);
// We need at least version 3.2 or higher to support geometry shaders
desc_.geometryShader &= ACG::openGLVersion(3,2);
loadLightingFunctions();
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment