Commit aa616606 authored by Hans-Christian Ebke's avatar Hans-Christian Ebke
Browse files

A little Qt4 backwards compatibility fix.


git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@18996 383ad7c9-94d9-4d36-a494-682f7c89f535
parent c5791512
...@@ -89,7 +89,6 @@ ...@@ -89,7 +89,6 @@
#include <QGraphicsWidget> #include <QGraphicsWidget>
#include <QGraphicsSceneDragDropEvent> #include <QGraphicsSceneDragDropEvent>
#include <QPropertyAnimation> #include <QPropertyAnimation>
#include <QOpenGLFramebufferObject>
#include <QMimeData> #include <QMimeData>
#include <QToolButton> #include <QToolButton>
...@@ -132,7 +131,11 @@ ...@@ -132,7 +131,11 @@
#include <QImageWriter> #include <QImageWriter>
#if QT_VERSION < 0x050000
#include <QGLFramebufferObject> #include <QGLFramebufferObject>
#else
#include <QOpenGLFramebufferObject>
#endif
#ifdef max #ifdef max
# undef max # undef max
...@@ -147,8 +150,6 @@ ...@@ -147,8 +150,6 @@
#include <OpenFlipper/common/GlobalOptions.hh> #include <OpenFlipper/common/GlobalOptions.hh>
#include <QGLFramebufferObject>
#include <OpenFlipper/common/RendererInfo.hh> #include <OpenFlipper/common/RendererInfo.hh>
#include <OpenFlipper/BasePlugin/PostProcessorInterface.hh> #include <OpenFlipper/BasePlugin/PostProcessorInterface.hh>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment