Commit 6d6ec482 authored by Jan Möbius's avatar Jan Möbius
Browse files

Removed check for Qt less than 5

parent d9366a5d
......@@ -111,7 +111,4 @@ void PostProcessorSobelPlugin::postProcess(ACG::GLState* _glstate, const std::ve
}
#if QT_VERSION < 0x050000
Q_EXPORT_PLUGIN2( postprocessorsobelplugin , PostProcessorSobelPlugin );
#endif
......@@ -62,9 +62,7 @@ class PostProcessorSobelPlugin : public QObject, BaseInterface, PostProcessorInt
Q_INTERFACES(BaseInterface)
Q_INTERFACES(PostProcessorInterface)
#if QT_VERSION >= 0x050000
Q_PLUGIN_METADATA(IID "org.OpenFlipper.Plugins.Plugin-PostProcessorSobel")
#endif
public:
PostProcessorSobelPlugin();
......
......@@ -55,29 +55,12 @@
#include "PostProcessorSobelPlugin.hh"
#if QT_VERSION >= 0x050000
#include <QOpenGLContext>
#else
#include <QGLFormat>
#endif
QString PostProcessorSobelPlugin::checkOpenGL() {
#if QT_VERSION < 0x050000
QGLFormat::OpenGLVersionFlags flags = QGLFormat::openGLVersionFlags();
if ( ! flags.testFlag(QGLFormat::OpenGL_Version_3_0) )
return QString("Insufficient OpenGL Version! OpenGL 3.0 or higher required");
// Check extensions
QString glExtensions = QString((const char*)glGetString(GL_EXTENSIONS));
QString missing("");
return missing;
#else
QOpenGLContext* context = QOpenGLContext::currentContext();
if ( context ) {
......@@ -97,6 +80,5 @@ QString PostProcessorSobelPlugin::checkOpenGL() {
return name() + QString(": No context available");
}
#endif
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment