Commit d238cf10 authored by Jan Möbius's avatar Jan Möbius
Browse files

Changed old macos from python 3.5 to 3.9 to support more recent pybind

parent 45d0cd51
Pipeline #20368 passed with stages
in 6 minutes and 41 seconds
......@@ -35,7 +35,7 @@ build-3.9-linux:
paths:
- dist3/
build-3.5-macos:
build-3.9-macos:
stage:
build
tags:
......@@ -44,7 +44,7 @@ build-3.5-macos:
GIT_SUBMODULE_STRATEGY: recursive
script:
- export PATH=/opt/local/bin:$PATH
- virtualenv -p python3.5 .
- virtualenv -p python3.9 .
- source bin/activate
- python setup.py bdist_wheel --dist-dir dist3
artifacts:
......@@ -94,17 +94,17 @@ test-3.9-linux:
- cd tests
- python -m unittest discover
test-3.5-macos:
test-3.9-macos:
stage:
test
tags:
- Apple
dependencies:
- build-3.5-macos
needs: [build-3.5-macos]
- build-3.9-macos
needs: [build-3.9-macos]
script:
- export PATH=/opt/local/bin:$PATH
- virtualenv -p python3.5 .
- virtualenv -p python3.9 .
- source bin/activate
- pip install dist3/*.whl
- cd tests
......@@ -155,14 +155,14 @@ deploy-3.9-linux:
paths:
- release/*.whl
deploy-3.5-macos:
deploy-3.9-macos:
stage:
deploy
tags:
- Apple
dependencies:
- build-3.5-macos
needs: [build-3.5-macos]
- build-3.9-macos
needs: [build-3.9-macos]
script:
- mkdir release
- cp dist3/*.whl release
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment